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APPENDIX B: LAB ANSWERS AND SOLUTIONS 

Lab 2.1 − Setting Window Options 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to set options for a window to determine 
the window's appearance and the controls used by the window. For this exercise, 
change the title of a window, remove its resize controls, and remove the control 
area on the window.  

Solution  
 

1. From the Microsoft Dynamics GP™ application navigate to the User 
Class Setup window. (TOOLS→SETUP→SYSTEM→USER CLASSES) 

2. When the User Class Setup window opens, select to modify the 
current window. (TOOLS→CUSTOMIZE→MODIFY CURRENT WINDOW) 

 
HINT: You can also navigate to the User Class Setup window from the Modifier. 
 

• Click the Forms button to open the Modified Forms window. 
• Click New to open the "Select a form to modify" window. 
• Select SY_User_Class from the forms list and click OK. 
• When the Form Definition appears, highlight the SY_User_Class window and 

click Open. 
 

 
3. When the window layout appears, click the perimeter of the window 

and move the pointer to the Properties window. 

4. Select the Object tab and make the following changes: 

 
Title Department Groups 
Resizable False 

 
5. Select the Visual tab and make the following changes: 

 
Control Area False 

 
6. Select Preview from the Layout menu to view your modifications.  

7. Close the preview window using the X in the corner.  
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8. Close the Window Layout, and save the changes to this window.  

9. From the File menu, select Microsoft Dynamics GP to return to the 
application. Navigate to the Security window, and make the 
following selections to set access to the modified window: 
TOOLS→SETUP→SYSTEM→SECURITY 

 
User ID Select the current user ID  
Company Fabrikam, Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series System 

 
10. Double-click Department Groups to set access to this modified 

window, and click OK to close the security window. 

11. Open the customized window to view it. 
(TOOLS→SETUP→SYSTEM→USER CLASSES)  
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Lab 2.2 − Changing the Opening Position of a Window 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to change the opening position of a 
window.  

Solution 
 

1. From the Microsoft Dynamics GP application, navigate to the 
Company Addresses Setup window by first opening the Company 
Setup Window. (TOOLS→SETUP→COMPANY→COMPANY) 

2. When the Company Setup window opens, click the Address button 
to open the Company Addresses Setup window. 

3. When the Company Addresses Setup window opens, select to 
modify the current window. (TOOLS→CUSTOMIZE→MODIFY CURRENT 
WINDOW) 

 
HINT: You can also navigate to the Company Addresses Setup window from the 
Modifier. 
 

• Click the Forms button to open the Modified Forms window. 
• Click New to open the "Select a form to modify" window. 
• Select SY_Company_Location from the forms list and click OK. 
• When the Form Definition appears, highlight the SY_Company_Location 

window and click Open. 
 

 
4. From the Layout menu, select Position Window.  

5. Drag the window so it appears in the lower right hand corner, and 
click the OK button to close the Position Window screen. 

6. Select Preview from the Layout menu to view your modifications. 

7. Close the preview window using the X in the corner.  

8. Close the Window Layout, and save the changes to this window.  
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9. From the File menu, select Microsoft Dynamics GP to return to the 
application. Navigate to the Security window, and make the 
following selections to set access to the modified window:  

(TOOLS→SETUP→SYSTEM→SECURITY) 
 

User ID Select the current user ID (Lessonuser1) 
Company Fabrikam, Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series Company 

 
10. Double-click the Company Addresses Setup selection to set access to 

this modified window, and click OK to close the security window. 

11. Open the customized window to view it.  

(TOOLS→SETUP→COMPANY→COMPANY) 
12. When the Company Setup window opens, click the Address button 

to open the Company Address Setup window. 
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Lab 3.1 − Modifying Individual Window Prompts 
Company: Fabrikam, Inc. 

 
Scenario: This exercise goes through the process of changing several prompts in 
the Company Setup Window's layout, as well as repositioning prompts and 
changing their color, font, and style. 

Solution 
 

1. From the Microsoft Dynamics GP application, navigate to the 
Company Setup window. (TOOLS→SETUP→COMPANY→COMPANY) 

2. When the Company Setup window opens, select to modify the 
current window. (TOOLS→CUSTOMIZE→MODIFY CURRENT WINDOW) 

 
HINT: You can also navigate to the Company Setup window from Modifier. 
 

• Click the Forms button to open the Modified Forms window. 
• Click New to open the "Select a form to modify" window. 
• Select SY_Company_Options from the forms list, and click OK. 
• When the Form Definition appears, highlight the SY_Company_Options 

window, and click the Open button.. 
 

 
3. With the layout of the window open, select the Static Text tool from 

the Toolbox. Move your cursor to the User Defined 1 text prompt 
and highlight it. Change the text to Category 1. Highlight the User 
Defined 2 text prompt, and change it to Category 2. 

 

 
 
4. Move the cursor back to the Toolbox to de-select the static text tool. 

Highlight both text prompts. This can be accomplished by multi-
selecting fields by holding down the control key as you select them. 
With both text prompts selected, move the cursor to the properties 
window. Change the following properties: 

FontBold = True 
FontColor = Pink 
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5. Select Preview on the Layout menu to view your modifications. 

6. Close the preview window using the X in the corner.  

7. Close the Window Layout, and save the changes to this window. 
Return to Microsoft Dynamics GP by selecting Microsoft Dynamics 
GP from the File menu. Set access to the new modified form using 
the Security window. (TOOLS→SETUP→SYSTEM→SECURITY) 

 
User ID Select the current user ID (Lessonuser1) 
Company Fabrikam, Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series Company 

 
8. Double-click the Company Setup selection to set access to this 

modified window, and click OK to close the security window. 

9. Open the customized window to view it. 
(TOOLS→SETUP→COMPANY→ COMPANY) 
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Lab 3.2 − Modifying Field Displays 
Company: Fabrikam, Inc. 

 
Scenario: This lesson goes through the process of modifying a window by 
changing how fields display information in the window. You have determined 
that the information displayed in the Company Addresses window is important 
for your data entry personnel to view, but you do not want to allow them to 
change certain information displayed for your company's multiple locations.  

Solution 
 

1. From the Microsoft Dynamics GP, navigate to the Company 
Addresses Setup window by first opening the Company Setup 
Window. (TOOLS→SETUP→COMPANY→COMPANY) 

2. When the Company Setup window opens, click the Address button 
to open the Company Addresses Setup window.  

3. When the Company Addresses Setup window opens, select to 
modify the current window. (TOOLS→CUSTOMIZE→MODIFY CURRENT 
WINDOW) 

 
HINT: You can also navigate to the Company Addresses Setup window from the 
Modifier. 
 

• Click the Forms button to open the Modified Forms window. 
• Select New to open the "Select a form to modify" window. 
• Select SY_Company_Location from the forms list and click OK. 
• When the Form Definition appears, highlight the SY_Company_Location 

window and click Open. 
 

 
4. Because you do not want certain users to have the ability to change 

or delete information in this window, select the following fields and 
assign the properties as indicated: 

 
Contact State Phone 1 Save Button 
Address 1 Zip Code Phone 2 Delete Button 
Address 2 County Phone 3  
City Country Code Fax  

 
HINT: Multiple fields can be selected at the same time by pressing the shift key and 
selecting all of the fields you want to change. Once all of the fields are selected, use the 
Properties window to change or set the properties. 
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5. Using the Properties window to set the following properties.  

 
Editable: False 
TabStop: False 

 
Your window should look as follows: 

 

 
 

6. Select Preview on the Layout menu to view your modifications. 

7. Close the preview window using the X in the corner.  

8. Close the Window Layout and save the changes to this window.  

 
NOTE: If you had not already done it in a previous exercise, in order to view your 
changes, you would need to set access to this modified window and open it. 
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9. From the File menu, select Microsoft Dynamics GP to return to the 
application. Navigate to the Security window, and make the 
following selections to set access to the modified window: 
TOOLS→SETUP→SYSTEM→SECURITY  

 
User ID Select the current user ID (Lessonuser1) 
Company Fabrikam, Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series Company 

 
10. Double-click the Company Addresses Setup selection to set access 

to this modified window, and click OK to close the security window. 

11. Open the customized window to view it. 
(TOOLS→SETUP→COMPANY→ COMPANY)  

12. When the Company Setup window opens, select the Address button 
to open the Company Address Setup window. 
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Lab 3.3 − Adding Fields to a Window 
Company: Fabrikam, Inc. 

 
Scenario: This lesson goes through the process of modifying a window by 
adding a field from the table that is linked to the window and by adding a new 
field that you can use later with Visual Basic for Applications. For this lesson, 
you add a new string field and a field from the RM_Customer_MSTR table to the 
Customer Maintenance window. You also create prompts for these new fields. 

Solution 
 

1. From Microsoft Dynamics GP, navigate to the Customer 
Maintenance window. (CARDS→SALES→CUSTOMER) 

2. When the Customer Maintenance window opens, select to modify 
the current window. (TOOLS→CUSTOMIZE→MODIFY CURRENT WINDOW) 

 
HINT: You can also navigate to the Customer Maintenance window from Modifier. 
 

• Click the Forms button to open the Modified Forms window. 
• Select New to open the "Select a form to modify" window. 
• Select RM_Customer_Maintenance from the forms list and click OK. 
• When the Form Definition appears, highlight the RM_Customer_Maintenance 

window and click Open. 
 

 
3. Make room for the Tax Registration Number field. It will be 

placed below the Tax Schedule ID field.  

4. One of the fields you add to the window is the Tax Registration 
Number. From the Toolbox, select the RM_Customer_MSTR table. 
Navigate to the Tax Registration Number, and drag it onto the layout 
placing it under the Tax Schedule ID field.  
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5. Add static text for the Tax Registration Number field. Highlight 
the static text and change the properties:   

 
Appearance 3D Highlight 
Border True 

 
 When complete, the window should look as follows: 

 

 
 

6. Resize the window area so that a new field can be added below the 
existing fields on the form. 

 

 
 

7. Create a new local string field to add to the window. Select Local 
Fields from the drop-down list in the Toolbox. Complete the Local 
Field Definition window using the following information: 

 
Field Name Email Address 
Control Type String 
Keyable Length 20 
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8. Select OK to add the new local field to the list. Drag the Email 
Address field from the list to the window layout placing it at the 
bottom left corner of the layout.  

9. Add a text prompt for the field. Using the text tool, place the pointer 
in the layout, and add a prompt for the field called Email Address. 
Select the text prompt, and using the Properties window, change the 
Visual properties of the text prompt to the following: 

 
Appearance 3D Highlight 
Border True 

 
10. Resize and reposition the text prompt so it aligns properly with the 

new field and the existing prompts. Click Link Prompt from the 
Tools menu to link the field to the Text Prompt. Select this option 
again to turn the Link Prompt option off.  

11. Change the tab sequence of the window so that the cursor stops at the 
new fields on the window. Since the Tax Registration Number is a 
non-editable field, do not include it in the tab sequence. The Email 
Address field should come after the User Defined 2 field. To set the 
tab sequence on the window, select Set Tab Sequence from the 
Layout menu. Press the tab key until you reach the Comment 1 
field. Double-click the Email Address so it gets included in the tab 
sequence before the Comment 1 field. Then hit the tab key to accept 
it, and the cursor will go to the Comment 1 field. Turn the tab 
sequence off by de-selecting it from the Layout menu. 

12. Select Preview from the Layout menu to view your modifications. 

13. Close the preview window by clicking the X in the corner.  

14. Close the Window Layout, and save the changes to this window.  

15. From the File menu select Microsoft Dynamics GP. Navigate to the 
Security window, and make the following selections to set access to 
the modified window: (TOOLS→SETUP→SYSTEM→SECURITY) 

 
User ID Select the current user ID  
Company Fabrikam, Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series Sales 

 
16. Double-click the Customer Maintenance selection to set access to 

this modified window, and click OK to close the security window. 
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17. Open the customized window to view it. 
(CARDS→SALES→CUSTOMER)  
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Lab 3.4 − Adding Fields to a Scrolling Window 
Company: Fabrikam, Inc. 

 
Scenario: This lesson goes through the process of modifying a window by 
adding a field from the table that is linked to the scrolling window. For this 
lesson, you add a Comment field from the IVC_HDR_WORK table to the 
Invoicing Document Inquiry window. You add the field to the Big Line Item 
section of the scrolling window. You also create a text prompt for this field. 

Solution 
 

1. From Microsoft Dynamics GP, navigate to the Invoicing Document 
Inquiry window. (INQUIRY→SALES→INVOICE) 

2. When the Invoice Document Inquiry window opens, select to modify 
the current window. (TOOLS→CUSTOMIZE→MODIFY CURRENT WINDOW) 

 
HINT: You can also navigate to the Invoicing Document Inquiry window from 
Modifier. 
 

• Click the Forms button to open the Modified Forms window. 
• Click New to open the "Select a form to modify" window. 
• Select IVC_Transaction_Inquiry from the forms list and click OK. 
• When the Form Definition appears, highlight the IVC_Transaction_Inquiry 

window and click Open. 
 

 
3. Once the layout of the IVC_Transaction_Inquiry window is 

displayed within Modifier, open the layout of the scrolling window 
by double-clicking on it.  

4. Using the Big Line Item selection under the Tools menu, make the 
big line item section area larger so the Comment field can be added. 
(TOOLS→MARK BIG LINE ITEM) 

 

 
 



Microsoft Official Training Materials for Microsoft Dynamics ™ 
Your use of this content is subject to your current services agreement 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Appendix B: Lab Answers and Solutions 

Page 307 

5. Select the IVC_HDR_WORK table from the Toolbox, and add the 
Comment field to the big line item area of the scrolling window. 
Place it below the other fields on the window. 

 

 
 

6. Select the appropriate properties for the Comment field so the color 
matches the other fields in the big line item area. 

 
BackColor Yellow 
Border False 
Pattern 75% Shading 
Size-Width 580 

 
7. From the Toolbox, select the Line Tool, and draw a horizontal line 

under the Comment field. The big line item area should look as 
follows: 

 

 
 

8. Close the layout of the scrolling window, and when prompted to 
save, discard, or cancel your changes, click Save. 

9. Resize the window to make room for the additional text prompt for 
the scrolling window. Move the scrolling window and the status area 
down. Select the Static Text tool from the Toolbox, and add a text 
prompt above the scrolling window identifying the Comment field 
that has been added. Select the following properties for the Text 
Prompt: 

 
BackColor System-List Header 2 
Border True 
Size-Width 596 
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10. Select Preview from the Layout menu to view the modifications. 

11. Close the preview window by clicking the X in the corner.  

12. Close the Window Layout and save the changes to this window.  

13. From the File menu select Microsoft Dynamics™ GP. Navigate to 
the Security window, and make the following selections to set access 
to the modified window: (TOOLS→SETUP→SYSTEM→SECURITY) 

 
User ID Select the current user ID (Lessonuser1) 
Company Fabrikam, Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series Sales 

 
14. Double-click the Invoicing Document Inquiry selection to set 

access to this modified window, and click OK to close the security 
window. 

15. Open the customized window to view it. (INQUIRY→SALES→INVOICE)  
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Lab 4.1 − Changing Data Formats 
Company: Fabrikam, Inc. 

 
Scenario: This lesson shows you how to change keyable lengths for data entry 
fields in Microsoft Dynamics GP and change the format the data type uses. For 
this lesson, your business only uses phone numbers that are ten digits in length, 
without an extension. Shorten the keyable length of phone number fields by 
changing the Phone_Number data type. 

Solution 
 

1. From Modifier navigate to the Phone_Number data type and click 
the Open button. Change the keyable length to 10, which only 
allows the user to enter ten characters. 

 

 
 

2. Click the buttons next to the attached Phone_Number format to open 
the Format Lookup window. 

3. With the Phone_Number format highlighted, click the Open button 
to open the Format Definition window. 

4. The format for this data type lists spaces rather than the zero if no 
phone number is displayed. The format will be numeric. Change the 
appropriate options:  

 
Fill Space 
String Options Numeric Only 
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5. Select the existing format from the Format Strings list. Modify it by 
taking off the extension. Click the Insert button to add the new 
format to the Format Strings column. Remove the format with the 
extension if it still exists in the list. This can be accomplished by 
highlighting the one with the extension and clicking the Remove 
button.  

 
Format String  (XXX) XXX-XXXX 

 

 
 

6. Click OK to save the changes to this format, and close the Format 
Definition window.  

7. Click OK to close the Format Lookup window.  

8. Click OK to close the Data Type Definition window.  
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9. Validate your changes by viewing The Company Setup window 
within Microsoft Dynamics GP. From the File menu click Microsoft 
Dynamics GP to return to the application. Select 
TOOLS→SETUP→COMPANY→COMPANY to open the Company Setup 
window. The phone number fields should look as follows: 
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Lab 4.2 − Modifying Push Button Data Types 
Company: Fabrikam, Inc. 

 
Scenario: This lesson shows you how to change a push button data type by 
changing the name of a push button globally. An accelerator key will also be 
added to the button.  

Solution 
 

1. Within Modifier, click Data Types to open the Data Types window. 
Select the PB_OK data type, and click Open to open the Data Type 
Definition window. 

2. Click the Static Values Lookup button. Change this button's Up 
caption, from "OK" to "&Accept." An ampersand is used by to 
indicate a keyboard equivalent or shortcut for a push button. With 
the ampersand appearing before the "A" in "Accept," the ALT+A 
button can be used to select this button. 

  

 
 

3. Click OK to return to the Data Type Definition window. Click OK 
to close the Data Type Definition window.  
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4. Validate the changes by viewing a window within Microsoft 
Dynamics GP such as the Company Setup window. From the File 
menu click Microsoft Dynamics GP. Navigate to the Company Setup 
window (TOOLS→SETUP→ COMPANY→COMPANY). The Company 
Setup window opens. Notice that the Accept button has replaced the 
OK button, and an underscore appears beneath the letter "A," 
indicating that the ALT + A key combination selects the button. 
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Lab 4.3 − Changing Strings in Microsoft Dynamics GP 
Company: Fabrikam, Inc. 

 
Scenario: This lesson goes through the process of changing text strings 
throughout Microsoft Dynamics GP. For this lesson, changing one global string 
alters all occurrences of that string throughout the dictionary. 

Solution 
 

1. Within the Microsoft Dynamics GP Modifier, select Strings from the 
Resources menu.  

2. When the Strings window appears, select Purchasing as the Core. 

3. Highlight the ZIP Code selection in the strings list, and then click the 
Open button. When the String Definition window appears, replace 
ZIP Code with the Postal code. 

 

 
 

4. Click OK to save the changes to the string.  
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5. Validate your changes by viewing a window within Microsoft 
Dynamics GP such as the Company Setup window. From the File 
menu select Microsoft Dynamics GP. Navigate to the Company 
Setup window (TOOLS→SETUP→ COMPANY→COMPANY). Since the 
change to the string is global and can be viewed in any company you 
use, you do not need to set access to view the changes. Postal code 
now appear where ZIP Code appeared before. 
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Lab 6.1 − Disabling Fields 
Company: Fabrikam, Inc 

 
Scenario: This exercise shows you how to use VBA code to disable a push 
button on a Microsoft Dynamics GP window. When a transaction is entered on 
the Payables Transaction Entry window, it has been decided that it should always 
be included as part of a batch. To eliminate confusion for the user, the Post 
button should be disabled on the window. 

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Payables 
Transaction Entry window. 
(TRANSACTIONS→PURCHASING→TRANSACTION ENTRY)  

2. With the Payables Transaction Entry window open, add the window 
to the VBA project by selecting (TOOLS→CUSTOMIZE→ADD CURRENT 
WINDOW TO VISUAL BASIC).  

3. After the window has been added to the VBA project, the field you 
want to disable can be added. Add the field to the VBA project by 
clicking TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. Once this 
option is turned on, click the Post button to add it to the VBA 
Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the 
Payables Transaction Entry window in the Project Explorer window 
in VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since you want to disable the button 
at all times, this code would best be placed on a Window Event. 
Select Window from the drop-down list, and then select the Before 
Open Event. 

7. Write the following code in the Window_BeforeOpen event: 
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HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly. 

 
8. Compile the code to verify it runs in Microsoft Dynamics GP.  

(DEBUG→ COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

10. If the Payables Transaction Entry window is open in Microsoft 
Dynamics GP, close it, and reopen the window again. The 
BeforeOpen event code should run, and the Post button should now 
be disabled. (TRANSACTIONS→PURCHASING→TRANSACTION ENTRY)  
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Lab 6.2 − Locking Fields 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to lock a field on a 
Microsoft Dynamics GP window. This exercise works with the Receivables 
Transaction Entry window. When the user selects a Debit or Credit Memo, the 
Document Date field populates with the current date. This date must be used for 
the transaction. Therefore you do not want to allow the user to enter the 
Document Date field to change it.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Receivables 
Transaction Entry window. (TRANSACTIONS→SALES→TRANSACTION 
ENTRY)  

2. With the Receivables Transaction Entry window open, add the 
window to the VBA project by selecting TOOLS→CUSTOMIZE→ADD 
CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the fields you 
want to work with can be added. Add the fields to the VBA project 
by clicking TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After 
this option is turned on, click the Document Type field and the 
Document Date field to add them to the VBA Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the 
Receivables Transaction Entry window in the Project Explorer 
window in VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since we want to lock the field only 
for a credit or debit memo, the code is placed behind the Document 
Type field. Select DocumentType from the drop-down list, and then 
select the Changed event. 

7. Write the following code in the DocumentType_Changed event: 
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HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Locked property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if 
something is not recognized or typed incorrectly. 

 
8. Compile the code to verify it runs in Microsoft Dynamics GP. 

(DEBUG→ COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

10. If the Receivables Transaction Entry window is open in Microsoft 
Dynamics GP, select the Debit Memos or the Credit Memo option 
from the Document Type drop-down list. Since the value of those 
choices equals 2 or 6, the code behind the changed event runs 
locking the Document Date field so the user cannot change it. 
(TRANSACTIONS→SALES→TRANSACTION ENTRY)  

 

 
 
NOTE: The Changed event was used in this exercise to ensure that every time the 
Document Type field is changed, the code fires. The else statement set the locked 
property to false if Debit Memos and Credit Memo is not the option selected. 
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Lab 6.3 − Setting Required Fields  
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to set a field on a Microsoft Dynamics 
GP window to be a required field using VBA code. This exercise works with the 
Invoice Entry window. The user must enter a value into the Freight field before 
the record can be saved or the window can be closed.  

Solution  
 

1. Within Microsoft Dynamics GP, navigate to the Invoice Entry 
window. (TRANSACTIONS→SALES→INVOICE ENTRY)  

2. With the Invoice Entry window open, add the window to the VBA 
project. (TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC).  

3. After the window has been added to the VBA project, the field we 
want to work with can be added. Add the field to the VBA project 
(TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC). After this option 
is turned on, click the Freight field to add it to the VBA Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the Invoice 
Entry window in the Project Explorer window in VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since you want the Freight field to 
always be a required field, use a window event. Select Window from 
the drop-down list, and then select the BeforeOpen event. 

7. Write the following code in the Window_BeforeOpen event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly. 
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8. Compile the code to verify it runs in Microsoft Dynamics GP. 
(DEBUG→ COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

10. If the Invoice Entry window is open in Microsoft Dynamics GP, 
close it and reopen the window again. The BeforeOpen event code 
runs, and the Freight field should now be required. 
(TRANSACTIONS→SALES→INVOICE ENTRY)  

 

 
 

NOTE: To view the required fields, turn this option on within Microsoft Dynamics GP. 
To accomplish this, select "Show Required Fields" from the Help menu.  
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Lab 6.4 − Conditionally Disabling Fields 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to disable a button on a 
Microsoft Dynamics GP window if a specific condition is met. This exercise 
works with the Invoice Entry window. If the total of a transaction is greater than 
$10,000, the Post button should be disabled. This ensures that the transaction is 
approved as part of a batch prior to its posting.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Invoice Entry 
window. (TRANSACTIONS→SALES→INVOICE ENTRY)  

2. If you completed the last exercise, the Invoice Entry window is 
already part of the VBA project. If not, add the Microsoft Dynamics 
GP window to the VBA project by selecting 
(TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC).  

3. After the window has been added to the VBA project, the fields we 
want to work with can be added. Add the fields to the VBA project 
by selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After 
this option is turned on, click the Post button and the Total field to 
add them to the VBA Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the Invoice 
Entry window in the Project Explorer window in VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since we want to disable the Post 
button if the total amount is greater than $10,000 use the changed 
event for the Total field. Select Total from the drop-down list, and 
then choose the Changed Event. 

7. Write the following code in the Total_Changed event: 
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HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly. 

 
NOTE: Since all field values returned to VBA are string values, numeric calculations 
may require you to convert he string value to the appropriate data type prior to 
performing the calculation. This example is using the CCUR() function to change the 
value to a currency value.  

 
8. Compile the code to verify it runs in Microsoft Dynamics GP.  

(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

10. If the Invoice Entry window is not open in Microsoft Dynamics GP, 
it can be opened by selecting TRANSACTIONS→SALES→INVOICE ENTRY. 
After the window is open, add a record and add some line items. 
When the Total reaches more than $10,000 the Post button should be 
disabled. 

 

 



Microsoft Official Training Materials for Microsoft Dynamics ™ 
Your use of this content is subject to your current services agreement 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Modifier with VBA in Microsoft Dynamics GP 9.0 

Page 324 

Lab 6.5 − Opening Lookup Windows 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to open a Lookup 
window from a Microsoft Dynamics GP window if a specific field is empty. This 
exercise works with the Purchase Order Entry window. When a user moves to the 
Vendor ID field and it is empty, the Vendor Lookup window should 
automatically open so that a vendor can be selected from the existing list.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Purchase Order 
Entry window. (TRANSACTIONS→PURCHASING→PURCH. ORDER ENTRY)  

2. With the Purchase Order Entry window open, add the window to the 
VBA project by selecting (TOOLS→CUSTOMIZE→ADD CURRENT 
WINDOW TO VISUAL BASIC).  

3. After the window has been added to the VBA project, the fields you 
want to work with can be added. Add the fields to the VBA project 
by selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After 
this option is selected, click the Vendor ID field and the Lookup 
button next to the Vendor ID field to add them to the VBA Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the 
Purchase Order Entry window in the Project Explorer window in 
VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since you want to open the Lookup 
window for the user if the Vendor ID is empty, use the 
BeforeGotFocus event for the Vendor ID field. Select VendorID 
from the drop-down list, and then select the BeforeGotFocus Event. 

7. Write the following code in the VendorID_BeforeGotFocus event: 
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HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly. 

 
8. Compile the code to verify it runs in Microsoft Dynamics GP. 

(DEBUG→ COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

10. If the Purchase Order Entry window is not open in Microsoft 
Dynamics GP, it can be opened by selecting 
TRANSACTIONS→PURCHASING→ PURCH. ORDER ENTRY. Tab through the 
fields in the window until you reach the Vendor ID field. The 
Vendor ID Lookup window automatically opens since the value of 
the Vendor ID field is blank.  
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Lab 6.6 − Changing Dialog Messages 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to change a Dialog 
Message on a Microsoft Dynamics GP window. This exercise works with the 
Customer Maintenance window. If the user tries to delete a record from the 
Customer Maintenance window and the title of that window has been changed to 
"Patient Maintenance," the dialog message that is displayed should refer to 
deleting patient records instead of customer records.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Customer 
Maintenance window. (CARDS→SALES→CUSTOMERS)  

2. Add the Microsoft Dynamics GP window to the VBA project by 
selecting TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC. 

3. After the resources have been added, switch to the VBA Editor. 
(TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR).  

4. Open the appropriate code window by double-clicking on the 
Customer Maintenance window in the Project Explorer window in 
VBA.  

5. To complete or test this project, the title of the Customer 
Maintenance window needs to be changed to display Patient 
Maintenance. Modifier or VBA can be used to accomplish this task. 
Use VBA to simplify the project. Within VBA, open the Properties 
window if not already displayed (VIEW→PROPERTIES WINDOW). 
Double-click on the Caption property to change the title of the 
window to display ".Patient Maintenance." Make sure to include the 
period before and after the text of the caption so the user knows the 
window was a Modified window and is also part of a VBA project. 
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6. With the code window open, select the drop-down to list the 
resources added to the project. Modal Dialog messages are not actual 
windows you can add to the project. However, the 
BeforeModalDialog event has special parameters available such as 
the PromptString parameter. You need to trap for the specific prompt 
string that appears in the Modal Dialog message. Select Window 
from the drop-down list, and then select the BeforeModalDialog 
Event. 

7. Write the following code in the Window_BeforeModalDialog event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly.  

 
8. Compile the code to verify it runs in Microsoft Dynamics GP. 

(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 
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10. With the Customer Maintenance window open, verify the new title 
displays ".Patient Maintenance." Use the browse buttons to navigate 
a record. If you try to delete that record, the modal dialog should 
now recognize that the title is Patient Maintenance and change the 
dialog message to ask them if they want to delete the patient record.  
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Lab 6.7 − Restricting Data in Fields 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to restrict the user 
from entering a specific value into a field on a Microsoft Dynamics GP window. 
This exercise works with the Receivables Transaction Entry window. This 
exercise restricts the user from entering C.O.D. in the Payment Terms field.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Receivables 
Transaction Entry window. (TRANSACTIONS→SALES→TRANSACTION 
ENTRY)  

2. If you completed the earlier exercise (Locking Fields Using VBA 
Code), the Receivables Transaction Entry window already exists in 
the VBA project. If you did not complete the earlier project, you 
need to add the Microsoft Dynamics GP window to the VBA project 
by selecting TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL 
BASIC.  

3. After the window has been added to the VBA project, the field you 
want to work with can be added. Add the field to the VBA project by 
selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After this 
option is turned on, click the Payment Terms field to add it to the 
VBA Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the 
Receivables Transaction Entry window in the Project Explorer 
window in VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since we want to restrict the user 
from entering C.O.D. in the Payment Terms field, this code is 
placed on the BeforeUserChanged event for the Payment Terms 
field. You will give them a warning message as well as keep the user 
in the Payment Terms field and stop any other Microsoft Dynamics 
GP code from running. Select PaymentTerms from the drop-down 
list, and then choose the BeforeUserChanged Event. 
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7. Write the following code in the PaymentTerms_BeforeUserChanged 
event: 

 

 

 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly.  

 
8. Compile the code to verify it runs in Microsoft Dynamics GP.  

(DEBUG→ COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 
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10. You should be logged in as lessonuser1. With the Receivables 
Transaction Entry window open, tab through the fields and enter 
data. When you reach the Payment Terms field, enter C.O.D. The 
message box displays a message that you cannot use C.O.D. Your 
focus should stay in that field and Microsoft Dynamics GP code 
should not have executed. 
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Lab 6.8 − Setting Drop-Down Fields 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to set the value of a 
drop-down field on a Microsoft Dynamics GP window. This exercise works with 
the Purchase Order Entry window. Set the default of the Type field to display 
Drop Ship.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Purchase Order 
Entry window. (TRANSACTIONS→PURCHASING→PURCH. ORDER ENTRY)  

2. If you completed the earlier exercise (Opening Lookup Windows 
Using VBA Code), the Purchase Order Entry window already exists 
in the VBA project. If you did not complete the earlier project, add 
the Microsoft Dynamics GP window to the VBA project by selecting 
TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the field you 
want to work with can be added. Add the field to the VBA project by 
selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After this 
option is turned on, click the Type field to add it to the VBA Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the 
Purchase Order Entry window in the Project Explorer window in 
VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since you want the Type field to 
default to Drop-Ship, this code must be placed on the BeforeOpen 
event for the Window. Select Window from the drop-down list, and 
then select the BeforeOpen Event. 

7. Write the following code in the Window_BeforeOpen event: 
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HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly.  

 
NOTE: "Type" is a reserved word in VBA in addition to being a field on the Purchase 
Order Entry window. To correctly identify the field in your VBA code, you need to fully 
qualify the field by using it in conjunction with its window name. 

 
8. Compile the code to verify it runs in Microsoft Dynamics GP. 

(DEBUG→ COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

10. If the Purchase Order Entry window is open, close it and reopen it so 
the Window event runs. You should now see the Type field default 
to Drop Ship.  
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Lab 6.9 − Calculating and Setting Field Values 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to calculate a 
percentage and set the value of a field on a Microsoft Dynamics GP window. 
This exercise works with the Receivables Transaction Entry window. If the Sales 
Amount is less than $50, the Freight should automatically calculate as 10% of the 
Sales Amount. If it is $50 or greater, the Freight should simply default as $5.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Receivables 
Transaction Entry window. (TRANSACTIONS→SALES→TRANSACTION 
ENTRY)  

2. If you completed one of the earlier exercises working with the 
Receivables Transaction Entry window, it already exists in the VBA 
project. If you did not complete the earlier project, you need to add 
the Microsoft Dynamics GP window to the VBA project by selecting 
TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the fields you 
want to work with can be added. Add the fields to the VBA project 
by selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After 
this option is turned on, click the Sales Amount field and the 
Freight field, and add them to the VBA Project. 

4. Switch to the VBA Editor. (TOOLS→CUSTOMIZE→VISUAL BASIC 
EDITOR).  

5. Open the appropriate code window by double-clicking on the 
Receivables Transaction Entry window in the Project Explorer 
window in VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since we want the calculation to 
occur when the Sales Amount changes, this code is placed on the 
AfterUserChanged event for the Sales Amount field. Select 
SalesAmount from the drop-down list, and then select the 
AfterUserChanged Event. 
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7. Write the following code:: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property you want to use such as the 
Enabled property. Type the code in lower case. When you tab off the line, VBA 
capitalizes and formats it appropriately. This is an easy way to visually tell if something 
is not recognized or typed incorrectly.  

 
8. Compile the code to verify it runs in Microsoft Dynamics GP.  

(DEBUG→ COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 
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10. In the Receivables Transaction Entry window, tab to the Sales 
Amount field and enter a value. Notice if the value is less than $50, 
then the Freight calculates the percentage. If it is more than $50, the 
Freight field should display $5.  
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Lab 7.1 − Setting Field Values in a Grid 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to set a default value 
for a field in a Grid. This exercise works with the GL Transaction Entry window. 
When the user enters the Grid, the Distribution Reference field in the Grid 
should default to a value that is the combination of the Journal Entry Number and 
the transaction's Reference.  

Solution  
 

1. Within Microsoft Dynamics GP, navigate to the GL Transaction 
Entry window. (TRANSACTIONS→FINANCIAL→GENERAL)  

2. Add the Microsoft Dynamics GP window to the VBA project by 
selecting TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the fields you 
want to work with can be added. Expand the scrolling window so all 
detail information is showing. Add the fields to the VBA project by 
selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After this 
option is selected click the following fields: 

– Journal Entry field 
– Reference field 
– Distribution Reference field in the Grid (When you click on 

this field, the name that appears in the VBA code window is 
Description. The picture below illustrates the scrolling window 
opened with Modifier so you can see the actual field names in 
the scrolling window.)  

 

 
 

4. Switch to VBA. (TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR).  

5. Open the appropriate code window by double-clicking on the GL 
Transaction Entry Detail grid in the Project Explorer window in 
VBA.  
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6. With the code window open, select the drop-down to list the 
resources added to the project. Since you want to set the value of the 
Distribution Reference (Description) field as the user enters the 
Grid, this code is placed on the BeforeLineGotFocus event for the 
Grid. Select Grid from the drop-down list, and then select the 
BeforeLineGotFocus Event. The value of the Distribution 
Reference (Description) field is set to a combination of the Journal 
Entry field and the Reference field. 

7. Write the following code in the Grid_BeforeLineGotFocus event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appear. Then select the property or method to use such as the 
focus method. Type the code in lower case. When you tab off the line, VBA capitalizes 
and formats it appropriately. This is an easy way to visually tell if something is not 
recognized or typed incorrectly.  

 
8. Compile the code to verify it runs in Microsoft Dynamics GP.  

(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by selecting the 
View Microsoft Dynamics GP button from the Toolbar. You can 
also select Microsoft Dynamics GP from the View menu. 
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10. In the GL Transaction Entry window tab to the Reference field and 
enter a value. Once you tab to the Grid, the event should run and 
populate the Distribution Reference (Description) field with the 
new value. 
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Lab 7.2 − Restricting Data in Grid Fields 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to restrict users from 
entering specific information into a field in a Grid for a Microsoft Dynamics GP 
window. This exercise works with the Invoice Entry window. If the line item's U 
of M is "Case," a message should be given indicating that they are not authorized 
to specify a unit of measure of that type. Focus should be set back to that field so 
another value can be entered.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Invoice Entry 
window. (TRANSACTIONS→SALES→INVOICE ENTRY)  

2. If you did not add the Invoice Entry window to the VBA exercise in 
a previous lesson, add the Microsoft Dynamics GP window to the 
VBA project by selecting TOOLS→CUSTOMIZE→ADD CURRENT WINDOW 
TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the field you 
want to work with can be added. The Grid must be active before a 
field can be added. Select the first record using the browse buttons so 
that the grid is active. Add the field to the VBA project by selecting 
TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After this option is 
selected click the following fields: 

– U of M field 
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4. Switch to VBA. (TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR)  

5. Open the appropriate code window by double-clicking on the Invoice 
Entry Detail grid in the Project Explorer window in VBA.  

6. With the code window open, select the drop-down to list the 
resources added to the project. Since you want to check the 
information the user entered into the U of M field and you want to 
keep them there if they entered "Case," this code is placed on the 
BeforeUserChanged event for the U of M field. Select UofM from 
the drop-down list, and then select the BeforeUserChanged Event. If 
the user is logged in as lessonuser1, do not populate the grid with 
customers that are in the USA. 

7. Write the following code in the UofM_BeforeUserChanged event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appear. Type the code in lower case. When you tab off the line, 
VBA capitalizes and formats it appropriately. This is an easy way to visually tell if 
something is not recognized or typed incorrectly.  

 
8. Compile the code to verify it runs in Microsoft Dynamics GP.  

(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)  

9. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by selecting the 
View Microsoft Dynamics GP button from the Toolbar. You can 
also select Microsoft Dynamics GP from the View menu. 

 

 
 



Microsoft Official Training Materials for Microsoft Dynamics ™ 
Your use of this content is subject to your current services agreement 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Modifier with VBA in Microsoft Dynamics GP 9.0 

Page 342 

10. Add some line items in the Invoice Entry window. If the user enters 
"Case" in the Unit of Measure field, the message appears telling 
them they cannot enter Case. The code stays in the field so the user 
can enter something else. 
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Lab 7.3 − Setting Field Values on Different Lines in a Grid 
Company: Fabrikam, Inc. 

 
Scenario: This exercise shows you how to use VBA code to set a default value 
for a field in a Grid from a different line item. This exercise works with the GL 
Transaction Entry window. When the user enters the Grid, the account number 
should default to the account number that was entered for the previous line of the 
scrolling window. For example, as focus moves to the second line in the grid, the 
account number should automatically be set to the account number that was 
entered for the first line item.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the GL Transaction 
Entry window. (TRANSACTIONS→FINANCIAL→GENERAL)  

2. If you have not added the window in a previous exercise, add the 
Microsoft Dynamics GP window to the VBA project by selecting 
TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the fields you 
want to work with can be added. Add the fields to the VBA project 
by selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. Once 
this option is selected click the Account Number field. 

 

 
 

4. Switch to VBA. (TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR)  

5. Open the appropriate code window by double-clicking on the GL 
Transaction Entry Detail grid in the Project Explorer window in 
VBA.  
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6. With the code window open, select the drop-down to list the 
resources added to the project. Since you want to set the value of the 
Account Number field as the user tabs to a new line item, the value 
of the Account Number from the previous line must be stored as a 
variable. The code you write will exist in two different events. The 
value of the Account Number entered for the first line item can be 
saved using the AfterLineLostFocus event for the Grid. The Account 
Number for the second line item can be set using the 
AfterLineGotFocus event for the Grid.  

7. Write the following code in the General Declarations section to 
declare the variable: 

 

 
 

8. Write the following code in the Grid_AfterLineLostFocus event: 

 

 
 

9. Write the following code in the Grid_AfterLineGotFocus event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Then select the property or method to use. Type the 
code in lower case. When you tab off the line, VBA capitalizes and formats it 
appropriately. This is an easy way to visually tell if something is not recognized or 
typed incorrectly.  
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10. Compile the code to verify it runs in Microsoft Dynamics GP.  
(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)  

11. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by selecting the 
View Microsoft Dynamics GP button from the Toolbar. You can 
also select Microsoft Dynamics GP from the View menu. 

 

 
 

12. In the GL Transaction Entry window, tab to the grid, and enter a line 
item. Select an account number and fill out the rest of the 
information for that record. When you tab to the next line item, the 
event should run and populate the Account Number with the same 
Account Number that was used on the previous line. 
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Lab 8.1 − Adding Fields to a Microsoft Dynamics GP Window 
Using Modifier 
Company: Fabrikam, Inc. 

 
Scenario: In this exercise, two new local fields will be added to a Microsoft 
Dynamics GP window using Modifier. Once the fields have been added, VBA 
code can be used in the following exercises to store, retrieve, delete, and update 
information in the DUOS table. This exercise works with the Vendor 
Maintenance window.  

Solution 
 

1. From the Microsoft Dynamics GP application, navigate to the 
Vendor Maintenance window by clicking 
CARDS→PURCHASING→VENDOR. 

2. When the Vendor Maintenance window opens, select the option to 
modify the current window. (TOOLS→CUSTOMIZE→MODIFY CURRENT 
WINDOW) 

3. Modify the window layout area to add room for the additional fields. 
Move the status area information down so the window looks like the 
following illustration: 

 

 
 

4. From the Toolbox, select Local Fields from the drop-down list, and 
click the New button to open the Local Field Definition window.  
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5. Using the following information, create two new local fields. 

 
Field Name URL Address 
Array Size 0 
Data Type Local 
Control Type String 
Keyable Length 31 

 
6. Click the Add button after creating the URL Address. 

 
Field Name General Satisfaction 
Array Size 0 
Data Type Local 
Control Type Drop-Down List 
Static Text Values Excellent, Good, Average, Fair, Poor 
Sort List Unmarked 

 
 Click the OK button after adding the General Satisfaction field to 

close the Local Field Definition Window. 

7. After the fields have been created, add them to the window layout.  

8. Using the Static Text Tool in the Toolbox, add static text for the two 
new fields. Once the static text has been added, change the following 
properties so the underline appears on the static text: 

 
Appearance 3D Highlight 
Border True 

 
9. The window should look like the following when finished: 
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10. Link the fields to their text prompts by choosing Tools-Link Prompt. 
You can also set the tab sequence so the URL Address and General 
Satisfaction come after the Ship Date.  Choose Layout-Set Tab 
Sequence. Tab until focus stops at the Account Number with 
Vendor Field. Double-click on the URL Address field, click the 
TAB key, then double-click on the General Satisfaction field.  
Click the tab and turn off tab sequence mode by de-selecting it from 
the menu. 

11. Select Preview from the Layout menu to view your modifications. 
Close the preview window clicking the X in the corner.  

12. Close the Window Layout, and save the changes to this window.  

13. From the File menu, select Microsoft Dynamics GP to return to the 
application. Navigate to the Security window, and make the 
following selections to set access to the modified window: 
(TOOLS→SETUP→SYSTEM→SECURITY). 

 
User ID Select the current user ID  
Company Fabrikam Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series Purchasing 

 
14. Double-click the Vendor Maintenance selection to set access to this 

modified window, and click OK to close the security window. 

15. Open the customized window to view it. 
(CARDS→PURCHASING→VENDOR)  
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Lab 8.2 − Retrieving From the DUOS Table 
Company: Fabrikam, Inc. 

 
Scenario: In this exercise, the two new local fields that were added to the 
Microsoft Dynamics GP window are retrieved from the DUOS table whenever 
the corresponding Microsoft Dynamics GP record is displayed. This exercise 
works with the Vendor Maintenance window.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Vendor 
Maintenance window. (CARDS→PURCHASING→VENDOR)   

2. Add the Microsoft Dynamics GP window to the VBA project by 
selecting TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the fields we 
want to work with can be added. Add the fields to the VBA project 
by selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. Once 
this option is selected click on the following fields: 

– URL Address field 
– General Satisfaction field 
– Vendor ID field 

 
4. Switch to VBA. (TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR).  

5. Open the appropriate code window by double-clicking the Vendor 
Maintenance window in the Project Explorer window in VBA.  

6. With the code window open, two variables need to be declared that 
will be used as the Collection and the Object. These variables need to 
be available to all procedures within that module. The variables 
should be declared in the General Declaration Section of the module 
under the Option Explicit statement. 

7. Write the following code in the General Declaration Section: 
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8. With the code window open select the drop-down to list the 
resources added to the project. Since we want to retrieve information 
about a specific vendor this code will be placed on the Changed 
event for the Vendor ID field. Select VendorID from the drop-down 
list, and then select the Changed Event. 

9. Write the following code in the VendorID_Changed event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Type the code in lower case. When you tab off the 
line, VBA capitalizes and formats it appropriately. This is an easy way to visually tell if 
something is not recognized or typed incorrectly.  

 
10. Compile the code to verify it runs in Microsoft Dynamics GP.  

(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)  

11. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

12. Since you have not created the code to "Save" the record to the 
DUOS table, you cannot test the code to retrieve it. Please complete 
all exercises regarding DUOS, and test each exercise when they are 
all complete.  

 
NOTE: The retrieve is done before the save to determine if the record exists. If no 
record is found, it is treated as a new blank record. 
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Lab 8.3 − Saving From the DUOS Table 
Company:  Fabrikam, Inc. 

 
Scenario: In this exercise, the two new local fields that were added to the 
Microsoft Dynamics GP window are saved to the DUOS table whenever the 
corresponding record is saved. This exercise works with the Vendor Maintenance 
window.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Vendor 
Maintenance window. (CARDS→PURCHASING→VENDOR)   

2. If you did not add the Vendor Maintenance window to the VBA 
project in a previous lesson, add the Microsoft Dynamics GP 
window to the VBA project by selecting TOOLS→CUSTOMIZE→ADD 
CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the fields you 
want to work with can be added. Add the fields to the VBA project 
by selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After 
this option is selected, click the Save button. 

4. Remember to deal with all possible situations such as when a modal 
dialog asks if you want to save the record. Check to see what 
message appears on the Modal Dialog prompting you to save the 
record. This might occur if a change is made to a record and you try 
to close the Microsoft Dynamics GP window. It can also occur if you 
change a record and try to select a different vendor using the browse 
buttons. Make a note of the exact wording of the prompt string that 
you will see. 

 

 
 

5. Switch to VBA. (TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR).  
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6. Open the appropriate code window by double-clicking the Vendor 
Maintenance window in the Project Explorer window in VBA.  

7. With the code window open, select the drop-down to list the 
resources added to the project. Since you want to save information 
about a specific vendor, this code is placed on the 
BeforeUserChanged event for the Save button. Select Save from the 
drop-down list, and then select the BeforeUserChanged Event. 

8. Write the following code in the Save_BeforeUserChanged event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Type the code in lower case. When you tab off the 
line, VBA capitalizes and formats it appropriately. This is an easy way to visually tell if 
something is not recognized or typed incorrectly.  

 
9. Write the following code to trap for the modal dialog in the 

Window_AfterModalDialog event: 

 

 
 

10. Compile the code to verify it runs in Microsoft Dynamics GP. 
(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)   
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11. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

12. Please complete all exercises regarding DUOS, and test each 
exercise when they are all complete. 
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Lab 8.4 − Deleting From the DUOS Table 
Company:  Fabrikam, Inc. 

 
Scenario: In this exercise, the two new local fields that were added to the 
Microsoft Dynamics GP window are removed from the DUOS table whenever 
the corresponding record is deleted. This exercise works with the Vendor 
Maintenance window.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Vendor 
Maintenance window. (CARDS→PURCHASING→VENDOR)   

2. If you did not add the Vendor Maintenance window to the VBA 
project in a previous lesson, add the Microsoft Dynamics GP 
window to the VBA project by selecting TOOLS→CUSTOMIZE→ADD 
CURRENT WINDOW TO VISUAL BASIC.  

3. After the window has been added to the VBA project, the field you 
want to work with can be added. Add the field to the VBA project by 
selecting TOOLS→CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After this 
option is selected, click the Delete button. 

4. Remember to deal with all possible situations such as when a modal 
dialog asks if you want to delete the record. Check to see what 
message appears on the Modal Dialog prompting you to delete the 
record. This modal dialog appears if you select the Delete button. 
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5. In addition, when deleting records you also need to deal with the 
possibility of another window appearing in Microsoft Dynamics GP 
stating that the record cannot be deleted. This is an actual window 
that can be added to the VBA project. Add this window to the project 
and write code to deal with the possibility of this window opening. 

 

 
 

6. To make this window appear, select an existing record using the 
browse buttons. Click the Delete button, and select the Delete option 
to delete the record. When this second window appears, add it to the 
VBA project by selecting the shortcut of CTRL+F11. (The menu is 
grayed so you need to use the keyboard equivalent.) The name of the 
window appears in VBA as Microsoft Dynamics GP. 

 

 
 

7. Switch to VBA. (TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR)  

8. Open the appropriate code window by double-clicking the Vendor 
Maintenance window in the Project Explorer window in VBA.  

9. With the code window open, three variables need to be declared that 
will be used with this exercise, two variables need to be available to 
all procedures within that module, and the third variable needs to be 
available to the Microsoft Dynamics GP window so it needs to be 
defined as a Public variable. The variables should be declared in the 
General Declaration Section of the module under the Option Explicit 
statement. 



Microsoft Official Training Materials for Microsoft Dynamics ™ 
Your use of this content is subject to your current services agreement 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Modifier with VBA in Microsoft Dynamics GP 9.0 

Page 356 

10. Add the lines of code that are circled to the General Declaration 
Section: 

 

 
 

11. The first thing the code needs to do is initialize the variables that 
were created. Since we want to delete information about a specific 
vendor, the code will save the current Vendor ID to the 
VendorIDtoDelete variable. This code will be placed on the Changed 
event for the Vendor ID. Select VendorID from the drop-down list, 
and then select the Changed Event. Since this code is running from 
the changed event on the Vendor ID field, the other two variables 
can be initialized as well. Add this code to the bottom of any existing 
code that exist for this field and event. 

 Add the lines of code that are circled to the VendorID_Changed 
event: 

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Type the code in lower case. When you tab off the 
line, VBA capitalizes and formats it appropriately. This is an easy way to visually tell if 
something is not recognized or typed incorrectly.  
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12. Write the following code to trap for the modal dialog in the 
Window_AfterModalDialog event: 

 

 
 

13. Write the following code in the Delete Button_AfterUserChanged 
event: 

 

 
 

14. Double-click on the Microsoft Dynamics GP window in the Project 
Explorer window in VBA to open the code window. Write the 
following code in the Microsoft_Dynamics_GP_AfterOpen event: 

 

 
 

15. Compile the code to verify it runs in Microsoft Dynamics GP. 
(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)   
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16. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

17. Please complete all exercises regarding DUOS, and test each 
exercise when they are all complete. You should be able to add, save, 
retrieve and delete the URL Address and General Satisfaction level 
for a customer. 
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Lab 8.5 − Selectively Deleting Records 
Company:  Fabrikam, Inc. 

 
Scenario: In this exercise, if you select the option to delete the Vendor from the 
Vendor Maintenance window, the record will only be deleted if the General 
Satisfaction level is not marked Excellent. Write a warning message stating the 
record cannot be deleted if the General Satisfaction level is excellent, and stop 
Microsoft Dynamics GP code from running and deleting the record from the 
Microsoft Dynamics GP table. This exercise works with the Vendor Maintenance 
window. 

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Vendor 
Maintenance window. (CARDS→PURCHASING→VENDOR)  

2. If you did not add the Vendor Maintenance window to the VBA 
project in a previous lesson, add the Microsoft Dynamics GP 
window to the VBA project by selecting TOOLS→CUSTOMIZE→ADD 
CURRENT WINDOW TO VISUAL BASIC.  

3. If you did not add the following resource in a previous project, add 
the following field to the VBA project by selecting TOOLS→ 
CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After this option is selected, 
click the Delete button. 

4. Switch to VBA. (TOOLS→CUSTOMIZE → VISUAL BASIC EDITOR)  

5. Open the appropriate code window by double-clicking the Vendor 
Maintenance window in the Project Explorer window in VBA.  
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6. Since you want to stop Microsoft Dynamics GP code from running 
and deleting the vendor if the General Satisfaction level is excellent, 
you should use the Keepfocus and the CancelLogic parameters. This 
code will be placed on the BeforeUserChanged event for the Delete 
button.  

 Select Delete from the drop-down list, and then select the 
BeforeUserChanged Event. Write the following code in the 
Delete_BeforeUserChanged event: 

 

 
 

7. Compile the code to verify it runs in Microsoft Dynamics GP.  
(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)  

8. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 
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9. Since all exercises are now complete in the DUOS section, test each 
exercise. 
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Lab 9.1 − Adding Fields to Existing Microsoft Dynamics GP 
Reports  
Company:  Fabrikam, Inc. 

 
Scenario: This exercise shows you how to add fields to existing Microsoft 
Dynamics GP reports using Report Writer. This exercise works with the Vendor 
List report. Since two fields were added to the Microsoft Dynamics GP Vendor 
Maintenance window in the previous chapter, the Vendor List report should also 
be modified to display those two new fields.  

Solution 
 

1. From the Microsoft Dynamics GP application, navigate to Report 
Writer. (TOOLS→CUSTOMIZE→REPORT WRITER)     

2. Select the Microsoft Dynamics GP product and click OK.  

3. Click the Reports button from the Toolbar to list the Microsoft 
Dynamics GP reports.  

4. Navigate to the Vendor List report, select it, and click the Insert 
button to add it to the Modified Reports List. 

 

 
 

5. Open the layout of the Vendor List report. Select Vendor List from 
the Modified Reports list, and click the Open button. From the 
Report Definition window, select the Layout button to modify the 
layout. 

6. Add two calculated fields to the Vendor List report to represent the 
additional fields on the maintenance window. Name the fields URL 
Address and General Satisfaction. Select Calculated Fields from 
the drop-down list on the Toolbox.  
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7. Click New to open the Calculated Field Definition window. Use the 
following information to create two new calculated fields. 

 
Name URL Address 
Result Type String 
Expression Type Calculated 

 
Constants Tab Type:    String 
 Constant: (Leave Empty) 

 
 Click the Add button to add the string to the Expressions Horizontal 

List Box. Click the OK button. 

 

 
 

8. Click New to open the Calculated Field Definition window. Use the 
following information to create two new calculated fields. 

 
Name General Satisfaction 
Result Type String 
Expression Type Calculated 

 
Constants Tab Type:    String 
 Constant: (Leave Empty) 
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 Click the Add button to add the string to the Expressions Horizontal 
List Box. Click the OK button. 

 

 
 

9. Make the body section area larger by clicking the "B" and dragging it 
down. After creating the new fields, add them to the body section of 
the report.  

 

 
 

10. Close the window layout clicking the X in the top corner. When 
prompted to save the changes, click the Save button. 
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Lab 9.2 − Populating Calculated Fields in Microsoft Dynamics 
GP Reports  
Company:  Fabrikam, Inc. 

 
Scenario: In this exercise, you need set the new calculated fields on the report to 
the values that were saved to the DUOS table from the modified Vendor 
Maintenance window. This exercise works with the Vendor List report.  

Solution 
 

1. Within Report Writer, navigate to the Vendor List report, select it 
and click the Insert button to add it to the Modified Reports List.  

2. Highlight the report, and click the Open button to view the Report 
Definition window. Click the Layout button to open the layout for 
the Vendor List report.  

3. Add the report to the VBA project by selecting TOOLS→ADD REPORT 
TO VISUAL BASIC.  

4. After the report has been added to the VBA project, the fields you 
want to reference using VBA code can be added. Add the following 
fields by holding down the control key as you select them.  

– Vendor ID field 
– URL Address field 
– General Satisfaction field 

 
 After they are all selected, go to TOOLS→ADD FIELDS TO VISUAL BASIC. 

5. Switch to VBA. (TOOLS→VISUAL BASIC EDITOR)  

6. Open the appropriate code window by double-clicking the Vendor 
List report in the Project Explorer window in VBA.  

7. You want to populate the URL Address and the General 
Satisfaction fields from the information stored in the DUOS table. 
Since the fields are listed in the Body section of the report, this code 
is placed on the BeforeBody event for the Report. Select Report from 
the drop-down list, and then click the BeforeBody Event.  
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8. Since you are working with the DUOS table, you need to write code 
to define the DUOS objects and declare variables. In addition, you 
will need to return the vendor collection you want to work with.  

 Next your code will return the values of the URL Address and the 
General Satisfaction fields from the table.  Drop-down lists are 
always stored in Microsoft Dynamics GP tables as integer values. 
Since the General Satisfaction field is a drop-down list, it is stored 
in the DUOS table as 1,2,3,4, and 5 instead of Excellent, Good, 
Average, Fair, and Poor. When the DUOS information is placed on a 
report, by default it appears as stored in the table. If you would like 
the corresponding text values to be shown, include additional code in 
your VBA event to translate those values. 

 

  
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Type the code in lower case. When you tab off the 
line, VBA capitalizes and formats it appropriately. This is an easy way to visually tell if 
something is not recognized or typed incorrectly.  
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11. Compile the code to verify it runs in Microsoft Dynamics GP.  
(DEBUG→COMPILE MICROSOFT_DYNAMICS_GP)   

12. Test the VBA code by viewing the Microsoft Dynamics GP report. 
Switch to Microsoft Dynamics GP by clicking the View Microsoft 
Dynamics GP button from the Toolbar. You can also select 
Microsoft Dynamics GP from the View menu. 

 

 
 

13. If the layout window for the Vendor List report is open, close the 
layout by clicking the X in the top corner. When asked to save the 
changes, click Save.  

14. From the Report Writer window, select Vendor List, and click the 
Print button to test the code. Select the check box to print it to the 
window. The two fields should now be populated with data. 

 

 
 

HINT: If you print the report in Microsoft Dynamics GP, make sure to grant access to 
the report using Microsoft Dynamics GP security. 
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Lab 10.1 − Adding Local Fields to a Microsoft Dynamics GP 
Window Using Modifier 
Company:  Fabrikam, Inc. 

 
Scenario: The next two exercises demonstrate how to add more fields to a 
Microsoft Dynamics GP window and populate them with information from 
another table within Microsoft Dynamics GP using ADO methods. Add data 
from the Item Master table (IV00101) to the Item Transaction Inquiry window.  
 
Since SQL statements and ODBC will be used, log in as "sa" for all exercises in 
this section. For the first exercise, two additional fields and a push button are 
added to the Microsoft Dynamics GP Item Transaction Inquiry window. This is 
done using Modifier.  

Solution 
 

1. Within Microsoft Dynamics GP, navigate to the Item Transaction 
Inquiry window: INQUIRY→INVENTORY→ITEM TRANSACTION. 

2. With the window, open add it to Modifier by selecting  
TOOLS→CUSTOMIZE→MODIFY CURRENT WINDOW.  

3. Modify the window layout area to add room for the additional fields. 
Two new fields are added under the Description field, and a push 
button is added in the status area of the window. The window should 
look like the following illustration: 
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4. From the Toolbox, select Local Fields from the drop-down list, and 
click the New button to open the Local Field Definition window.  

5. Using the following information, create three new local fields. Click 
the Add button after creating the Short Name and Standard Cost 
fields. Then click the OK button after adding the PB Update 
Standard Cost button to close the Local Definition Window. 

 
Field Name Short Name 
Array Size 0 
Data Type Local 
Control Type String 
Keyable Length 15 

 
Field Name Standard Cost 
Array Size 0 
Data Type Local 
Control Type Currency 
Keyable Length 15 
Format DLR_RBS0_STR$ 

 
Field Name PB Update Standard Cost 
Array Size 0 
Data Type Local 
Control Type Push Button 
Static Values Text - Picture 
Up Caption Update Standard Cost 

 
6. After the fields have been created, add them to the window layout.  

7. Using the Static Text Tool in the Toolbox, add static text for the two 
new fields. After the static text has been added, change the following 
properties so the underline appears on the static text: 

 
Appearance 3D Highlight 
Border True 

 
8. Link the Text Prompts with their associated fields. This option is 

under the Tools menu.  

9. Change the property for the Short Name field to be editable = false. 
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10. The window should look like the following when finished: 

  

 
  

11. Select Preview from the Layout menu to view your modifications 
Close the preview window clicking the X in the corner.  

12. Close the Window Layout, and save the changes to this window.  

13. From the File menu, click Microsoft Business Solutions-Dynamics 
GP to return to the application. Navigate to the Security window and 
make the following selections to set access to the modified window 
(TOOLS→SETUP→SYSTEM→SECURITY). 

 
User ID Select the current user ID  
Company Fabrikam Inc. 
Product Microsoft Dynamics GP 
Type Modified Windows 
Series Inventory 

 
14. Double-click Item Transaction Inquiry selection to set access to the 

modified window, and click OK to close the security window. 

15. Open the customized window to view it. (INQUIRY→INVENTORY→ITEM 
TRANSACTION)  

 
NOTE: For details about adding new fields to a Microsoft Dynamics GP window, 
refer to the "Customizing Windows" section of the Modifier Training workbook. 
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Lab 10.2 − Populating Local Fields with Data Using ADO and 
VBA Code 
Company:  Fabrikam, Inc. 

 
Scenario: This exercise demonstrates how to populate the local fields added in 
the last exercise with information from another table within Microsoft Dynamics 
GP using ADO methods. Specifically, you must add data from the Item Master 
table (IV00101) to the Item Transaction Inquiry window. 
 
Since SQL statements and ODBC will be used, log in as "sa" for all exercises in 
this section. 
 
In this exercise, an example of ADO methods is used in the IV Item Transaction 
Inquiry window. The form is changed with Modifier to add the Short Name and 
Standard Cost for the item. VBA code is written to retrieve this data and display 
it on the Inquiry window. There is also a button to allow you to update the 
Standard Cost information from the Inquiry Screen. Typically, you do not have 
an Update button on an Inquiry Window. We are demonstrating this only for the 
purpose of showing the update functionality.  

Solution 
 

1. If the window is not open, navigate to the Modified Item Transaction 
Inquiry window: INQUIRY→INVENTORY→ITEM TRANSACTION. 

2. Add the Modified Item Transaction Inquiry window to the VBA 
project by selecting TOOLS→CUSTOMIZE→ADD CURRENT WINDOW TO 
VISUAL BASIC.  

3. Add the following fields to the VBA project by clicking TOOLS→ 
CUSTOMIZE→ADD FIELDS TO VISUAL BASIC. After this option is selected, 
click the following: 

– Item Number field 
– Short Name field 
– Standard Cost field 
– Update Standard Cost button 

 
4. Switch to VBA. (TOOLS→CUSTOMIZE→VISUAL BASIC EDITOR)  

5. Open the appropriate code window by double-clicking the Item 
Transaction Inquiry window in the Project Explorer window in 
VBA.  



Microsoft Official Training Materials for Microsoft Dynamics ™ 
Your use of this content is subject to your current services agreement 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Modifier with VBA in Microsoft Dynamics GP 9.0 

Page 372 

6. A reference must be marked to the ADO library so methods and 
properties can be accessed. Mark a reference by selecting 
TOOLS→REFERENCES. Find the Microsoft Active Data Objects 
Library you want to use, and check it. Then click OK.   

 

 
 

7. Use standard VBA syntax to declare variables used for objects from 
external applications. Create the objects you need using the Set 
statements inside the VBA procedure. The following code shows 
variables declared to use ADO methods in the IV Item Transaction 
Inquiry window. These variables are declared in the General 
Declaration section of the IV Item Transaction Inquiry window. 
Select General from the drop-down list, and then add the following 
code to the Declarations Event.  

 

 
 
HINT: If you type the resource name correctly when typing the period, a list of 
methods and properties appears. Type the code in lower case. When you tab off the 
line, VBA capitalizes and formats it appropriately. This is an easy way to visually tell if 
something is not recognized or typed incorrectly.  
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8. Establish a connection to the database through the ODBC data 
source. Only execute this once within a session, if possible. 
Therefore, this connection is defined in the BeforeOpen event of the 
Window. Select Window from the drop-down list, and then add the 
following code to the BeforeOpen Event.  

 

 
 

HINT: Depending on what your ODBC driver is, the Data Source in your VBA code 
might need to be changed. 

 
9. Close the ODBC connection. This connection is closed in the 

AfterClose event of the Window. Select Window from the drop-
down list, and then add the following code to the AfterClose Event.  
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10. After defining the database connection and closing the connection, 
write code to retrieve the data on the screen. This code is placed in 
the Changed event of the Item Number. Select ItemNumber from the 
drop-down list, and then add the following code to the Changed 
event.  

 

 
 

HINT: A recordset created solely for reading data should be created differently for 
performance optimizations. 

 
11. A button was added to the window to update the Standard Cost 

information. This code is placed in the BeforeUserChanged event of 
the Update Standard Cost button. Select UpdateStandardCost from 
the drop-down list, and then add the following code to the 
BeforeUserChanged Event.  

 

 
 

NOTE: For detailed information on ADO, refer to the Microsoft ActiveX Data Objects 
help file, ADO210.CHM, located on your hard drive. The specific location of the file 
may vary based upon the operating system being used. 
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12. Compile the code to verify it runs in Microsoft Dynamics GP.  
(DEBUG→COMPILE DYNAMICS_GP) 

13. Test the VBA code by viewing the Microsoft Dynamics GP window 
in run mode. Switch to Microsoft Dynamics GP by clicking the View 
Microsoft Dynamics GP button from the Toolbar. You can also 
select Microsoft Dynamics GP from the View menu. 

 

 
 

14. Test this exercise by navigating to the Item Transaction Inquiry 
window (INQUIRY→INVENTORY→ITEM TRANSACTION). Select a record 
using the Browse buttons. Change the Standard Cost and click the 
Update Standard Cost button. The new value should be saved to 
the table. 
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